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What’s new 

Firmware 

Firmware V 1.0.3: 
Integration of AlgaeTorch 100 pressure measurement 

Firmware V 1.0.4: 
Integration of cell counts and 2-point calibration 

Firmware V 1.0.7: 
Integration of 2-point turbidity calibration 
Integration of correction factor 

Firmware V 1.1.0: 
Integration of interval measurement 

Firmware V 2.1.0: 
Integration of GPS 

Hardware 

Series 03 and up 
Delivery of the AlgaeTorch with attachment for shallow water. 

Series 04 and up 
Integrated GPS module. 

Series 04-040 and up 
Magnetic switch to start the AlgaeTorch alternatively to the tilt action mechanism. 

Please Note: 

Decimal points are according to local settings of Windows, i.e. internationally, the decimal point is “ . ” but in 
most of Europe it is „ , “. Please pay attention to this. Most import/export difficulties are caused by the use of the 
“point” or “comma” and vice versa. The software screenshots contain “decimal commas”, i.e. the European 
system. 
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General Safety Precautions 

 
The bbe AlgaeTorch is an instrument for determination of the concentration of chlorophyll in water. It should 
only be used for this purpose. 
 
Only instructed staff should operate this instrument. 
 
Consult appropriate safety manual in case of using hazardous compounds and solutions. Wear gloves, coat and 
safety goggles. 
 
Electrical connection of the instrument should only be carried out by trained staff. 
 
The connector at the bbe AlgaeTorch (100m version) has to be supplied with grease periodically. 
 
The instrument should only be opened by authorised staff. 
 
Changes to electrical connections and circuits may cause damage to the instrument and lead to loss of 
warranty. 
 

Cleaning the instrument: 

The instrument should be cleaned after use. The use of aggressive cleaning fluids or water at high pressure 
should be avoided. Neither should any mechanical cleaners or apparatus come into contact with the sensor 
head or LED display. Attention: in order to obtain exact measurement results, the measuring head should be 
free from grease. 
Before stowing the instruments should be cleaned of dirt under running water. If necessary, normal, 
commercially available washing up liquid can be used. Rub the instrument dry with a soft cloth and take care 
when drying the electrical contacts. 
The simplest way to store the instrument for any length of time is in its original case, in which the accessories 
can also be stored and kept dry. 

Supplement to the safety instructions  

Performing electrical connection may only be carried out by trained personnel. Maintenance, such as e.g. 
exchanging the rechargeable battery pack, may only be carried out by personnel trained and authorised by bbe 
Moldaenke. Replacement parts and repair materials must be issued/released by bbe Moldaenke for each case. 
 
 
 

Storage (longer periods) 

Clean the instrument before storage. 
Store the instrument dry and frost free. 
 
NiMH-Cells show a certain amount of self-discharge. When you store your device for a period of several weeks 
without operation, please proceed as follows: 

1. Generally charge the battery completely (e.g. over night) before you store the device. 

2. Get the device out of the stock every two or three months (respectively once a year for devices Series 6 

and higher) and: 

a. charge the battery for about 6 hours.  
b. discharge the battery by starting a continuous measurement - let the measurement run until the battery is 
empty and the device switches off automatically  
 
Note: only operate the device willingly until automatic switch off when you did the above mentioned 
firmware-has the following version (or higher): 

⧫ 2.34 (for AlgaeTorch/BenthoTorch 1 = Series 1 to 5) 
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⧫ 3.05 (for AlgaeTorch/BenthoTorch 2 = Series 6 and higher) 

c. charge the battery completely before you store the device 

Please note: After this procedure all earlier measuring results in the internal storage of the Torch will be 
overwritten! We recommend to download your results to a bbe++ database before doing the procedure above. 
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Quick start instructions 

To use the AlgaeTorch instrument immediately, please refer to the following two pages. If more detailed 

information is required, please go to chapter ”Use of the AlgaeTorch”. 

1. Charge the AlgaeTorch by using the power supply connected to the small cable housing of the USB

cable.

2. Start the AlgaeTorch by turning it upside down and back again in one quick movement.

If the AlgaeTorch is equipped with a reed switch to switch it on with a magnet, a symbol is printed on the label of 
the AlgaeTorch. Please tip on the symbol with the magnet to switch the AlgaeTorch on. The magnetic switch 
can be used alternatively to the tilt mechanism (described above). 

3. Use a wrist strap to secure the instrument.

4. Ensure that the connector is closed with the cap.

5. Go to “Start measurement”.

6. Dip the AlgaeTorch in the water. Ensure a sufficient distance from the water bed and that no fluorescent

material such as leaves are nearby. This may influence the measurement. Please use the attachment for

shallow water in this case. Move the AlgaeTorch slightly to avoid air bubbles at the front window. These air

bubbles might influence the measuring results.

7. In the lab, please use the bbe calibration vessel.

Tip this point with a 
magnet to start the 
AlgaeTorch 



Quick start instructions 

bbe AlgaeTorch Manual Page 9 

> 25cmIn case of fluorescing matter on 
the ground, please use the attachment 
for shallow water.

8. If there is an internal GPS module available and activated, the status of the GPS signal is shown. If the

given quality criteria are met, the measurement starts automatically, otherwise, the poor positioning

information can be used (takepos) or the GPS information can be skipped.

PosFix    Num  Quali 
YES    4  95% 

takepos.  skip 

If there is no GPS signal e.g. within buildings, only “skip” is available. 

9. During the internal calibration a decreasing number of  #  is shown.

############### 
############### 
#####   

During the measurement the remaining time is displayed: 

measuring 
time remaining 

5 s 

The end of the measurement is signalled by a short vibration. The result can be read from the display: 

Cyano:  10.3µg/l 
Total:  42.7µg/l 
OK   
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Operating Principles and Design 

Principles of Operation 

FLUORESCENCE 

 
The AlgaeTorch is a fluorometer made for quick and easy total chlorophyll and cyanobacteria measurements. 
 
Due to the fact that algae of the same division contain a similar quantity and quality of photosynthetic pigments, 
their fluorescence excitation spectrum (with a fixed emission wavelength at 680nm) is significant. Thus, it is 
possible to differentiate divisions of algae by their fluorescence excitation spectrum.  

The bbe AlgaeTorch for algae differentiation uses 7 LEDs for fluorescence excitation. The LEDs emit light at 3 
selected wavelengths (470nm, 525nm, 610nm).  

 

 

 

TURBIDITY  

An additional LED is used optionally for turbidity measurements based on the reflected light of any particles in 
the water. 

The turbidity measurement is based on backscattering. The calibration is done with Formazin. 

The results are shown in FTU (Formazin turbidity units). This result is also used to perform a turbidity 
compensation of the chlorophyll measurement. Consequently, the chlorophyll measurement in turbid water is 
enhanced by the turbidity measurement. 

GPS MODULE  

The AlgaeTorch is equipped with a global positioning system module to determine the exact position of the 
measurement. In single-mode the longitude and latitude are stored together with the measurement results and 



Operating Principles and Design 

bbe AlgaeTorch Manual   Page 11 

can be transferred to a PC for further evaluation. In interval- or continuous-mode the GPS data will not be stored 
in memory.  
 
The bbe++ software contains a feature to export the data to a so-called *.KMZ file to display the data in Google 
Maps. 
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Design 

MEASUREMENTS 

• total chlorophyll

• cyanobacteria

• pressure sensor (AlgaeTorch 100)

• turbidity sensor

OPERATION 

• cable-free operation

• display on the instrument

• datalogger

• internal rechargeable batteries

• internal display

• 4 capacitive softkeys

• vibration feedback

• position sensors to start the AlgaeTorch

• power-down features

Sensor head with 
LEDs and photodiode  

Connector  

Display  

4 capacitive keys  

Carrying eye  

Pressure sensor 
(AlgaeTorch 100)  

GPS module 

Magnetic
switch
switch
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Versions 

10 M VERSION 

This version is made for use in shallow water. It is rated down to 10 m. For underwater operation, please 
ensure that the cap of the connector is closed. It is watertight as rated only in this configuration. 

100 M VERSION 

This version is made for use in shallow water and deeper water down to 100m. It is equipped with an 
underwater connector so that data can also be read out from below the surface. Additionally it is equipped with 
a pressure sensor. 

ATTACHMENT FOR SHALLOW WATER 

To prevent fluorescence readings influenced from benthic algae or seaweed the AlgaeTorch is delivered with an 
attachment for shallow water. Please use this attachment when measuring near the river or lake bed. 

To fasten the shallow water attachment, please use a so-called knurled screw, which you will find in the 
accessories for the AlgaeTorch. 
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Use of the AlgaeTorch 

Wrist strap or carrying cable/rope  

 
On top of the AlgaeTorch there is an eye to mount a wrist strap or carrying cable/rope. 
 

 
 

 

USB connecting cable of the AlgaeTorch 

 
The AlgaeTorch comes with a connecting cable. This cable has two functions: connecting the Torch to a PC and 
connecting a power supply to the torch. 
 

 
Power supply 

connector 

Connector for 
the AlgaeTorch 

USB connector 
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There are two versions available. One for the AlgaeTorch 10 equipped with a standard connector and one for 
the AlgaeTorch 100 equipped with a submersible connector. 
 
 

 
 

RS232 / Modbus (RS232) connecting cables of the AlgaeTorch (option) 

 
There are two types of RS232 cables available for the AlgaeTorch. One type is equipped with a standard RS232 
connector to be used with a PC and one is delivered without a connector for stationary use. 
 
 

 
 
The one without a connector is intended to be used together with a data logger. The numbers of the cables are 
printed on the black wires. 
 

Submersible 
connector 
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Number Function 

1 + 12V 

2 GND 

3 RxD 

4 TxD 

 

Power supply of the AlgaeTorch 

 
The AlgaeTorch comes with a power supply to charge the AlgaeTorch and use it continuously. The power 
supply comes with different country-specific mains plugs. Choose the connector for your country and click in 
onto the power supply as shown below. 
 

 
 

Use of the AlgaeTorch with the power supply 
 

⧫ Connect the small end of the cable to the box of the “connecting cable” of the AlgaeTorch.  

⧫ Connect the power supply to the mains. 

⧫ If the internal battery is not fully charged, charging will start (see below, page 17) 
 

Wires with 
imprint  
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When using the power supply, the AlgaeTorch will not switch off completely, but the display illumination will be 
turned off after some minutes if the touch keys have not been used. 

Charging the AlgaeTorch with the power supply 

 

⧫ Connect the small end of the cable to the box of the “connecting cable” of the AlgaeTorch.  

⧫ Connect the power supply to the mains. 
 
The AlgaeTorch will start up and show the charging process by moving bars in the battery symbol. 
 

bbe AlgaeTorch  
01.06.2008         
12:00:00    menu 

 
When the internal battery is charged completely, the battery symbol will be completely filled and it will stop 
moving. 

Starting the AlgaeTorch 

 
The AlgaeTorch is equipped with a position sensor. To switch it on, turn the AlgaeTorch upside down and back 
again in one quick movement.  

 
 
The AlgaeTorch then switches on. Please confirm the start of the instrument by touching the corresponding left 
key. Do not touch any key during the turning procedure. 

 

bbe AlgaeTorch 
switch torch on? 
YES               NO 

 
The confirmation is done in order to avoid unwanted starts, for example during transport. 
 
If the AlgaeTorch is equipped with a reed switch to switch it on with a magnet, a symbol is printed on the label of 
the AlgaeTorch. Please tip on the symbol with the magnet to switch the AlgaeTorch on. The magnetic switch 
can be used alternatively to the tilt mechanism (described above). 
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After confirmation, a start-up message with the current time and the status of the internal battery appears: 

bbe AlgaeTorch 
01.06.2008 
12:00:00  Menu 

Press the right key to enter the main menu. 
Automatic Power-Down 

If the AlgaeTorch is being used without a power supply, it switches off automatically after 5 minutes without any 
operation. It then has to be re-started as described above. 

Operation Modes / Air Pressure Compensation 

Three operation modes can be used with the AlgaeTorch. 

⧫ Single mode:

after starting, one measurement is carried out. The end of the measurement is indicated by a

vibration. Afterwards the result is displayed.

In the case of the AlgaeTorch100 with integrated pressure sensor, an air pressure measurement is

taken before the AlgaeTorch is submersed and  the measurement starts. This is necessary since the

air pressure influences the depths measurement.

⧫ Continuous  mode:

The AlgaeTorch operates continuously with the given parameters Measuring Time. The

measurements are executed directly one after the other.

To interrupt the auto-mode measurement, turn the Algae Torch upside down and back again as

described in the “Starting the AlgaeTorch” section.

In the case of the AlgaeTorch100 with integrated pressure sensor, an air pressure measurement is

taken before the first measurement starts. This is necessary since the air pressure influences the

depths measurement. So please submerse the AlgaeTorch100 after the measurement has started.

⧫ Interval  mode:

The AlgaeTorch operates continuously with the given parameters Measuring Time and Interval.

If the interval is longer than the measuring time, the AlgaeTorch switches off between the

measurements.

To interrupt the auto-mode measurement, turn the Algae Torch upside down and back again as

described in the “Starting the AlgaeTorch” section.

In the case of the AlgaeTorch100 with integrated pressure sensor, an air pressure measurement is

taken before the first measurement starts. This is necessary since the air pressure influences the

depths measurement. So please submerse the AlgaeTorch100 after the measurement has started.

Tip this point with a 
magnet to start the 
AlgaeTorch 



Use of the AlgaeTorch 

bbe AlgaeTorch Manual   Page 19 

Operation of the AlgaeTorch by Capacitive Touch Keys 

 

 
 

The AlgaeTorch is equipped with 4 capacitive keys with vibration feedback. The keys are located below the 
display. To actuate a key, just touch the marked area. The actuation is reconfirmed by the AlgaeTorch via a 
short palpable vibration. 
 
The current function of each key is shown on the display. 
 
The keys are calibrated during the start-up of the instrument. Please do not touch the keys during the switch-on 
procedure. 
 
Please operate the touch keys as follows, in order to prevent the accidentally activation of 2 keys at the same 
time: 
 

                     
 
During submersion, the keys are deactivated. This is recognised by detecting more than one key pressed at the 
same time. The keys are reactivated when the keys are dry again. 

Storing the AlgaeTorch 

The best way to store the AlgaeTorch is in the original case. The cable and the accessories can also be stored 
in this case. 
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Structure of the Internal Software 
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Start 
measurement 

Data Power-down Settings Calibration 

   View    Mode   Offsets 
   Delete    Measuring time       Ultrafiltrated 
       Measuring interval       Distilled 
   ..Auto Power off   Fingerprints 
     Clock       Green algae (high / low) 
         Time       Cyano (high / low) 
         Date       Cell count factors 
         Sync GPS time          cyano/chlorophyll/others 
         UTC time shift ..Dye 
         Dayli. saving      Set dye 
     Display      Check dye 
         Brightness   Turbidity  
         Contrast       Slope (high / low) 
     Unit       offset 
     GPS    Pressure (option) 
         Position       Show depth 
         On/off       Set air pressure 
         Req. Quality       Set low point 
         Version        Set high point 
     Serial protocol   Voltage 
     Software version       Show 
          calibrate 
      Factory settings 
      Correction factor 
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NAVIGATION WITHIN THE SOFTWARE 

The software is structured in menus with different layers. For an overview, please see above. 
 

 
<  SETTINGS  > 

OK   <-   ->   ESC 
 
 

SETTINGS:            
<      Mode      > 
OK   <-   ->   ESC 

 
 

SETTINGS:MODE 
<      Single      > 
OK   <-   ->   ESC 

 
 

Functions of the keys: 
 
OK: To choose the item shown and enter the submenu 
ESC: To discard the changes and leave the menu 
<- ->: To navigate within the same menu level. 

ENTERING SETTINGS 

To change the settings of the AlgaeTorch, choose the parameter in the SETTINGS menu: 
 

Measuring time:  
   10s                
OK   +     -   ESC 

 
The underlined number is currently changeable by using the + and – keys. 
 

OK: Confirms the underlined number and moves the cursor one position to the right. If the last number is 
underlined, OK confirms the new setting and returns to the SETTINGS menu. 

+ / -: Changes the currently underlined number 
ESC: Cancels the input and returns to the SETTINGS menu. 
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Operating the bbe AlgaeTorch 

Measuring Procedure 

The AlgaeTorch was calibrated before delivery with the bbe standard algae types.  

SINGLE DIP-IN MEASUREMENT 

⧫ Start the AlgaeTorch. 

⧫ Use a wrist strap to secure the instrument. 

⧫ Ensure that the connector is closed with the cap. 

⧫ Go to “Start measurement”. 

⧫ Dip the AlgaeTorch in the water. Ensure a sufficient distance from the water bed and that no 

fluorescent material (such as leaves) are nearby. This may influence the measurement. Please use 

the attachment for shallow water in this case. Move the AlgaeTorch slightly to avoid air bubbles at the 

front window. These air bubbles might influence the measuring results. 

⧫ In the lab, please use the bbe calibration vessel. 
 

> 25cmIn case of fluorescing matter on 
the ground, please use the attachment 
for shallow water.

 
 

⧫ If there is an internal GPS module available and activated, the status of the GPS signal is shown. If 

the given quality criteria are met, the measurement starts automatically, otherwise, the poor 

positioning information can be used (takepos) or the GPS information can be skipped. 
 

PosFix    Num     Quali 
YES        4        95% 

takepos.             skip 
 

In case there is no GPS signal e.g. within buildings, only “skip” is available. 

⧫ During the internal calibration a decreasing number of  #  is shown . 
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############### 
############### 
#####                

 

⧫ During the measurement the remaining time is displayed: 
 

measuring 
time remaining 

5 s 
 

⧫ The end of the measurement is signalled by a short vibration 

⧫ The result can be read from the display: 
 

Cyano:  10.3µg/l 
Total:  42.7µg/l 
           more  OK 

 
More shows the depth / turbidity (if available): 

 

Depth:      5.3 m 
Turb.:  20.2 FTU   

        more  OK 
 

PROFILING / CONTINUOUS MEASUREMENT 

⧫ Start the AlgaeTorch 

⧫ Use a carrying cable/rope to secure the instrument 

⧫ Ensure that the connector is closed with the cap / dummy connector 

⧫ Do not exceed the maximum depth (10 m / 100 m). 

⧫ Use the continuous mode (Settings -> Mode -> Continuous) 

⧫ Adjust measuring time and interval 

⧫ Go to “Start -> Start continuous measurement” 

⧫ Submerse the AlgaeTorch 

⧫ To stop the AlgaeTorch, turn it upside down and back between two measurements when the 

AlgaeTorch switches of because of the selected measuring interval. If the measuring interval is 0 s, 

use the exit key between two measurements: 
 

Cyano:  10.3µg/l 
Total:  42.7µg/l 
                exit 

 

⧫ To read the data, go to “Data -> View” 

MOORED OPERATION 

Moored operation is similar to the profiling operation. Please note:  
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⧫ The maximum number of readings is 1000.  

⧫ During a longer period of mooring, biofouling may occur. Please contact bbe for anti-biofouling 

devices. 

Display unit 

 
The measured concentrations of the AlgaeTorch can be displayed either in µg chl-a/l or in cell counts (cells/l). 
The cell counts are calculated from the chlorophyll concentration by individual factors for each algae class. 

Data Menu / View data 

 
The data menu contains the commands for data handling. 

DATA -> VIEW 

To view the measured data go to “Data -> View”: 

 
The display shows the date and time of the latest result.  

More: 

Displays the result of the chlorophyll measurement. In case of activated depth and/or turbidity measurement, 
these results will be displayed by  touching “more” again. 

 

27.08.2008        
15:23:00           
more  <-  ->  ESC 

 
More shows the algae concentrations: 

 

Cyano:  10.3µg/l 
Total:  42.7µg/l 
more  <-  ->  ESC 

 
More shows the depth / turbidity (if available): 

 

Depth:      5.3 m 
Turb.:  20.2 FTU 
more  <-  ->  ESC 

 
More shows the longitude / latitude (if available): 

 

54°20.3644`N 
10°05.8699`E 

more  <-  ->  ESC 
 



Operating the bbe AlgaeTorch 

bbe AlgaeTorch Manual   Page 26 

Arrow keys: 

Please use the arrow keys to navigate to the required result. 
 

27.08.2008        
15:23:00           
more  <-  ->  ESC 

 
->  shows later results: 

 

27.08.2008        
15:23:01           
more  <-  ->  ESC 

 
->  shows later results: 

 

27.08.2008        
15:23:02           
more  <-  ->  ESC 

 
The arrow keys also function when the concentration or depth is shown: 
 

Cyano:  10.3µg/l 
Total:  42.7µg/l 
more  <-  ->  ESC 

 
->  shows later results: 

 

Cyano:  12.3µg/l 
Total:  45.1µg/l 
more  <-  ->  ESC 

 
->  shows later results: 

 

Cyano:  15.1µg/l 
Total:  49.6µg/l 
more  <-  ->  ESC 

 
In case of cell count results, the display appears as follows: 
 

Cyano:252E5 c/l 
Total:114E5 c/l 
more  <-  ->  ESC 

 

ESC: 

Returns to the main menu. 
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DATA -> DELETE 

Deletes all data from the memory of the AlgaeTorch. 
 

DATA-DELETE      
       all         

OK   <-   ->   ESC 
 

OK Deletes all data from the memory. 

Settings Menu 

OVERVIEW  

Mode Single, continuous or interval measurements 
Pressure mode Set air pressure automatically at the begin of the measurement 
Autostart* Start a measurement automatically after switching on 
Measuring duration Set the duration of a single measurement (default = 10s) 
Measuring interval Set the interval between two measurements in interval mode  
Clock -> time Set time 
Clock -> date Set date 
Display -> Contrast Set the contrast of the display 
Display -> Brightness Set the brightness of the display 
Unit Toggle between µg/l and cell count 
GPS Read the current position / GPS settings 
Software Version Displays the software version 

MODE  

Changes between single, continuous and interval measurement. 
 

SETTINGS:MODE 
<      Single      > 
OK   <-   ->   ESC 

 

SETTINGS:MODE 
<   Continuous   > 
OK   <-   ->   ESC 

 

SETTINGS:MODE 
<   Interval   > 
OK   <-   ->   ESC 

 

⧫ Single: One single measurement is performed after starting. 

⧫ Continuous: The AlgaeTorch performs one measurement directly after the other. 

⧫ Interval: Performs one measurement after the other with the given measuring interval. 
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MEASURING DURATION 

Sets the duration of a single measurement (default = 10s) 
 

Measuring dur.: 
   10 s    

OK    +    -    ESC 
 

MEASURING INTERVAL 

Sets the interval between two measurements in interval mode  

AUTOPOWERDOWN 

Sets the time after which the AlgaeTorch is automatically turned off, when not operated. It is also possible to 
disable this function. In this case the BenthoTorch will not be switched off. There are several predefined periods 
available by using the + and – keys.  

 

AutoPowerDown 
after   5 minutes 
OK    +    -    ESC 

 
One additional option is to disable the power down: 

 

AutoPowerDown 
disabled 

OK    +    -    ESC 
 

The option is disabled in continuous operation. 

CLOCK -> DATE 

Sets the date 
 

SETTINGS:DATE 
   15.02.09    

OK    +    -    ESC 
 

CLOCK -> TIME 

Sets the time  
 

SETTINGS:TIME 
   15:32:43    

OK    +    -    ESC 
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DISPLAY -> CONTRAST 

Sets the contrast of the display (0-16). The result can be seen directly on the display. 
 

Set contrast 
   7    

OK    +    -    ESC 
 

DISPLAY -> BRIGHTNESS 

Sets the brightness of the display. The result can be seen directly on the display. The brighter the display, the 
more power is used by the display. 
 

Set brightness 
   50 %    

OK    +    -    ESC 
 

UNIT 

Switches from µg chl-a/l to cell counts. The calculation of the cell counts is performed using the factors given in 
the calibration menu. 

GPS 

See GPS chapter for details. 

SERIAL PROTOCOL 

Sets the serial protocol of the AlgaeTorch. If a protocol different to bbe standard is selected, the AlgaeTorch will 
not communicate with bbe++. To communicate with bbe++ please set the protocol to bbe standard. 
 

 

SETTINGS-PROTO: 
bbe standard 

OK   <-   ->   ESC 
 

The protocol “bbe standard” is the protocol to communicate with the bbe++ PC software.  
 
The data of the AlgaeTorch can also read by MODBUS.  

 
 

SETTINGS-PROTO: 
Modbus RTU 19200 
OK   <-   ->   ESC 
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SETTINGS-PROTO: 
Modbus RTU 9600 
OK   <-   ->   ESC 

 
There are 2 possibilities to work with MODBUS RTU via RS232. The difference is the baud rate 19200 or 9600. 
 
For details please see the chapter “How to access to an AlgaeTorch/BenthoTorch by ModBus”.  

 
 

SETTINGS-PROTO: 
"  AOA protocol   
OK   <-   ->   ESC 

 
The “AOA protocol” is the protocol that is also used in. the bbe AlgaeOnlineAnalyser. It is a proprietary protocol 
defined by bbe. For details please see the chapter “AOA Protocol”. 
 

SOFTWARE VERSION 

Displays the software version and serial number. This is useful information to help bbe service answer specific 
questions. 

 

S.Nr. Ato-03-002 
SW ver. 1.04 

OK                     
 

Calibration Menu 

 
The calibration menu is password-protected to prevent it from unintentional changes. 

 

Enter Password:  
     0  0  0  0      
OK   +     -   ESC 

 
The default password is 1234.  

Fingerprint calibration procedures 

The AlgaeTorch has to be calibrated with two algae classes: 
 

⧫ Green algae 

⧫ Cyanobacteria 
 

2 calibration concentrations are required for each algae class. Additionally the calibration of the offset has to be 
performed. For the offset measurement, ultra-filtrated sample water (free of algae) is used. 

CALIBRATION OF THE OFFSET: 

2 types of offsets need to be calibrated: 

http://dict.leo.org/ende/index_de.html#/search=proprietary&searchLoc=0&resultOrder=basic&multiwordShowSingle=on&pos=0
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1. Offset distilled water. This is used as 0 for the turbidity measurement 
2. Offset ultrafiltrated water. This is used as 0 for the chlorophyll measurement. The ultrafiltrated water 

contains no algae, but so called yellow substances. This are other fluorescing substances, that are no 
algae 

 

⧫ Avoid artificial light during the calibration, especially fluorescent lamps!  

⧫ Submerse the AlgaeTorch in the ultra-filtrated sample water and use “Calibration -> Offsets” 

Calibration solution for the „ultra filtrated water offset and the yellow substances 

 
In the lab, the calibration of the yellow substances can be easily done with tap water. In cases of very small 
chlorophyll-a concentration, it is recommended to use ultrafiltered sample of the water (from the water to be 
examined). For this the following equipment is needed: 
Type of filter:Nitrocellulose filter, pore size 0.45 µm, diameter 47mm (for example: Sartorius Stedim) 
Vessels: Depending on the sample volume flask with 5 L content  
Negative pressure of 800mbar. The volume of the sample is determined by the instrument to be calibrated, 
BBE. For an ALA be about 100ml, requires approximately 5L filtrate for an AOA / AlgaeGuard / A-Tox sensor / 
AlgaeTorch about 1L and for an immersion probe.  
 

CALIBRATION OF THE ALGAE FINGERPRINTS: 

The calibration of the fingerprints has to be performed in 2 steps: one low calibration point and one high 
calibration point. We recommend using 30-50µg/l for the lower point and 100-150µg/l for the higher point. After 
calibrating one point, the value is stored for 1 hour. Within this time the second calibration point has to be 
measured. Otherwise, the first calibration point will be deleted when re-entering the calibration menu. 

 

⧫ Do an offset calibration before calibrating the algae classes. 

⧫ For the calibration of the algae fingerprints, please use pure solutions of the algae class with a known 

chlorophyll concentration. The concentrations should be in the ranges of 30-50µg/l and 100-150µg/l. 

⧫ Avoid artificial light during the calibration, especially fluorescent lamps!  

⧫ Submerse the AlgaeTorch in the solution. 

⧫ Choose “Calibration -> Fingerprints” in the software, choose the algae class 

⧫ Choose the corresponding low or high concentration 
 

Calibration of:  
<Cyano low conc> 
OK   <-  ->   ESC 

 

⧫  and enter the concentration. 
 

Enter known 
Conc.: 036.0 µg/l 
OK    +    -    ESC 

 

⧫ OK starts the calibration. 

⧫ Apply the values after the calibration. 

⧫ Re-perform the same procedure with the high concentration between 100 and 150 µg/l within a 

maximum time of one hour. 

⧫ Re-perform the whole procedure with green algae. 
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SETTING THE CELL COUNT FACTORS: 

The ratio of cell counts and chlorophyll concentration has to be determinated by microscopic investigation for 
each algae class. The default values given in the AlgaeTorch are based on several investigations from the 
literature. The numbers need to be confirmed for the specific location. 
 
To set the cell counts go to “Calibration” -> “Fingerprints” -> “Cell Count factors”. It is possible to enter three 
different factors: one for cyanobacteria, one for green algae and one for others. 

 

Cyano factor 
1000000 

OK    +    -    ESC 
 

CHECK OF THE INSTRUMENT USING A DYE (OPTION) 

To check the performance of the AlgaeTorch the Performance Test Attachment can be used: 
 

 
 

The attachment contains a dye that is fluorescing when excited by any of the LED used in the AlgaeTorch. As 
soon as the AlgaeTorch is calibrated, the attachment can be applied to the AlgaeTorch and the fluorescence 
values can be stored (set dye). 
 
To check the performance of the AlgaeTorch the attachment has to be applied to the AlgaeTorch, a 
measurement is performed and the result is compared to the stored values. 
 
The dye is temperature sensitive – so the temperature has to be measured and entered during the setting and 
the checking procedure. The temperature sensor is delivered together with the test attachment.  
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The results of different Performance Test Attachments might vary from one attachment to the other. So the test 
has to be performed with the same attachment all the time. 

Procedure 

⧫ Mount the Performance Test Attachment and the temperature sensor. Take care for the right position 

of the attachment. 

⧫ Start a continuous measurement at the AlgaeTorch 

⧫ Switch on the temperature sensor 

⧫ Let the instrument run for 10 minutes 

⧫ Proceed with “set dye” for storing the fluorescence values  

⧫ Proceed with “check dye” for evaluating the performance of the instrument 

Set dye 

The set dye procedure is used to store the fluorescence pattern of a dedicated test attachment in the 
AlgaeTorch. This is the reference for the check dye procedure. 

⧫ go to Calibration -> dye -> set dye 
 

enter dye temp.: 
20.0°C 

OK    +    -    ESC 
 

⧫ Enter the temperature of the thermometer and confirm with OK 

⧫ The AlgaeTorch performs a fluorescence measurement. The results are shown afterwards 

⧫ Confirm to use the shown values as a new reference. Use ESC to retain the stored values. 

Check dye 

⧫ Go to Calibration -> dye -> check dye 
 

enter dye temp.: 
20.0°C 

OK    +    -    ESC 
 

⧫ Enter the temperature of the thermometer and confirm with OK 

⧫ The AlgaeTorch performs a fluorescence measurement and displays the result of the check. 
 

CALIBRATION-DYE 
Check Dye: OK 
OK                 

 

CALIBRATION-DYE 
Check Dye: Fail 
OK                 

 
In case of a failed test, please check, if the Performance Test Attachment is mounted properly and the 
temperature is measured correctly. Contact the bbe service, if the error remains. 
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Turbidity calibration procedures  

The AlgaeTorch is equipped with a turbidity measurement. The calibration is done in three steps: 
 

1. Offset calibration in clean water 

2. Turbidity calibration with a low concentration of turbidity standard (20-40FTU) 

3. Turbidity calibration with a high concentration of turbidity standard (120-170FTU) 

CALIBRATION OF THE TURBIDITY OFFSET: 

⧫ For the calibration of the offset, please use tap water or distilled water. Take care that the calibration 

water and the window of the AlgaeTorch is free of bubbles. 

⧫ Avoid artificial light during the calibration, especially fluorescent lamps!  

⧫ Submerse the AlgaeTorch in the water and use “Calibration -> Turbidity -> Offset” 

CALIBRATION OF THE TURBIDITY SLOPE: 

The calibration of the turbidity slope has to be performed in 2 steps: one low-calibration point and one high-
calibration point. We recommend using 20-40 FTU for the lower point and 120-170 FTU for the higher point. 
After calibrating one point, the value is stored for 1 hour. Within this time the second calibration point has to be 
measured. Otherwise the first calibration point will be deleted when re-entering the calibration menu. 

 

⧫ Do an offset calibration before calibrating the turbidity slope. 

⧫ For the calibration of the algae fingerprints, please use a turbidity standard. The concentrations should 

be in the ranges of 20-40FTU for the lower point and 120-170FTU for the higher point. 

⧫ Avoid artificial light during the calibration, especially fluorescent lamps!  

⧫ Submerse the AlgaeTorch in the solution. 

⧫ Choose “Calibration -> Turbidity -> Slope” in the software, choose the corresponding low or high 

concentration 
 

Calibration of:  
<Turb. low conc> 
OK   <-  ->   ESC 

 

⧫  and enter the concentration. 
 

Enter known 
Conc.:  20.1 FTU 
OK    +    -    ESC 

 

⧫ OK starts the calibration. 

⧫ Apply the values after the calibration. 

⧫ Re-perform the same procedure with the high concentration between 120 and 170 FTU within a 

maximum time of one hour. 
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SHOW DEPTH: 

 

 Current depth:  
       2.5 m        

OK                      
 

Shows the measured depth with the current calibration. 

SET AIR PRESSURE: 

 

CALIBRATION:PRES 
<Set air press.> 
OK   <-   ->   ESC 

 

Air pressure set 
completed 

OK   <-   ->   ESC 
 

“Set air pressure” can be used to compensate the current air pressure. This is used to show the depth option 
(see above). During the measurement, the air pressure is set automatically at the beginning of the first 
measurement. 

Internal Temperature 

The internal temperature of the AlgaeTorch can be shown.  

SHOW INTERNAL TEMPERATURE: 

 

Int. Temperature:  
       25.5 °C        
OK                       

 
Shows the internal temperature. 

Voltage 

The voltage of the internal rechargeable battery can be shown and calibrated.  

SHOW VOLTAGE: 

 

Battery voltage:  
       6.35 V        

OK                       
 

Shows the measured voltage with the current calibration. 
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CALIBRATE VOLTAGE: 

Calibration of the voltage should only be done by the bbe service only. 

Factory settings 

 
To reset the instrument to the factory settings including the factory calibration, please use this menu. 

 

Restore factory 
settings??        
ESC              OK 

 
Choose OK to reset the settings to the original values. 

Correction factor 

 
The determination of chlorophyll depends on the method of analysis. Even if a lab obtains consistent results – 
for example by diluting – the variation from one lab to another can be enormous. To fit the total chlorophyll 
concentration to your method, this factor can be used. The default setting is 1. To obtain a result which is 10% 
higher, choose 1.1. 

 

gl. corr fact. 
1.00 

OK    +    -    ESC 
 
 
 

Connecting the bbe AlgaeTorch / BenthoTorch / AlgaeLabAnalyzer via USB to a PC 

To connect the bbe AlgaeTorch, BenthoTorch or AlgaeLabAnalyser to a PC a USB driver has to be installed 
first. 
 
Hint: 
Older versions of the converter do not work with Windows 8 and up. Please contact the bbe service. 
 

USB DRIVER SET-UP 

Please insert the bbe CD again. Then, start the application PL2303_Prolific_DriverInstaller.exe in the folder  
<CD-Drive>:\driver\PL2303_Prolific_DriverInstaller 
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Please restart the PC. After that you will find the USB COM port in the system configuration (in this case 
COM5): 

 

This port is used in the PC software to communicate with the Instrument. 
 



bbe++ Software 

bbe AlgaeTorch Manual   Page 38 

bbe++ Software 

The bbe++ software is delivered together with bbe instruments. If a PC is delivered with the instrument or 
integrated in the instrument, the software is already installed. 
It provides the following functions: 
 

• operation, control and calibration of bbe instruments 

• data analysis and display in tables and diagrams 

• export in different formats 
 
This chapter describes the general functions of the bbe++ software. The examples may show data or 
parameters of other bbe instruments. The data and parameters of your instrument can easily be handled 
accordingly. Whenever this manual deals with special features of a certain instrument, this will be explained in 
the special instrument chapter. 
The data and parameters of the instruments are stored in a database. A single database may contain the data 
of different instruments of the same type and also different types of instruments. 

Software Set-Up 

The software is stored on a CD delivered with the instrument. The latest version can also be downloaded from 
the bbe website after registration (http://www.bbe-moldaenke.de/log-in/ ). 
The Windows autorun function should start the installation automatically. If it does not, open the Explorer and 
click on setup.exe on the CD for installation. 
Welcome window: click “NEXT >” 
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Choose the destination folder and click “NEXT >” 

 

Choose a new start menu folder and click “NEXT >” 

 

Choose your preferred language and click “NEXT >” 
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Final success window of the bbe++ installation. Click “FINISH”. 

 

DESKTOP ICON OF THE BBE++ SOFTWARE 

The setup installs an icon for the bbe++ software on the desktop (if chosen during installation). 

 

BBE++ SOFTWARE IN THE START MENU 

The bbe++ folder in the start menu contains: 
➢ bbe++ software 
➢ installed manuals  
➢ link to the data folder of bbe++ 
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Software Update 

Updates of the bbe++ software and manuals can be downloaded from the bbe website http://www.bbe-
moldaenke.de after registration. 

Structure of the software 

The following menus are available in the bbe++ software. Whether a menu is displayed, depends on the access 
level set. 

• FILE contains all the input/output functions. 

• EDIT contains functions to copy data and graphics. 

• PARAMETER contains functions to set the parameters of an instrument and to adapt the parameters of data 

already measured. 

• VIEW contains functions to show and hide toolbars. 

• WINDOW contains functions to show the data in different types of tables and graphics as well as editors to 

change the layout (advanced functionality level only) 

• TOOLS contains options to change settings that influence the behaviour of the bbe++ software and the way 

of operating the instruments. 

• CALIBRATION contains the items to calibrate different bbe instruments (advanced functionality level only) 

• HELP contains information about the current bbe++ version. 
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Menu structure (“Basic functionality”) 
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Menu structure (”Advanced functionality”) 
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General considerations for storing and displaying data and parameters in bbe++ 

WHAT IS STORED IN A BBE++ DATABASE? 

The measuring results and instrument parameters of different bbe instruments are stored. It is possible to 
retrieve the corresponding instrument parameters for each single result. 
In the so-called “Summary View” the serial numbers of the instruments and the time ranges for all data stored in 
this database are shown. This view can be used to select the desired data as well as the corresponding 
parameters for display. 
The database files are marked with the extension *.bdb (bbe database) 
 

WHERE IS THE DATABASE STORED? 

The database of bbe++ is stored in the standard application folder of Windows. The name of the folder depends 
on the operation system and the language. For example: C:\ProgramData\bbe++ in the Windows 7 English 
version. To access this folder easily, there is a link in the file menu of bbe++ or start menu of Windows called 
“Data directory”: 
 

 

HOW TO DISPLAY THE DATA? 

In the bbe++ software, different views have been pre-defined for each instrument: 

• graphics 

• tables 

• single dataset 

• data export 
 
User-defined views may be added as well.  

SIMULTANEOUS DISPLAY OF DATA OF DIFFERENT TYPES OF INSTRUMENTS 

After opening a database file, the data of different instruments of the same type may be displayed 
simultaneously. To display the data of another type of instrument from the same database file, this file can be 
opened more than once.  
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WHO CAN ACCESS TO THE PARAMETERS OF THE INSTRUMENTS? 

The bbe++ software has 2 access levels – basic functionality and advanced functionality. Depending on the 
different access levels, more or fewer menu items and parameters are shown. There are different settings for 
reading or writing access. The advanced functionality level can be password protected. 
 

DESKTOP OF THE BBE++ SOFTWARE. 

 
 
 
 
 
 

 
 
 
 
 
 

TOOLBAR 

Toolbar to navigate within the datasets. 

TOOLBAR INSTRUMENT 

Toolbar to operate the instrument 

Toolbar 
 

Data table 

Graph 1 
 

Serial number, voltage of 
the battery, internal clock  
 

Graph 2 
 

Toolbar 
Instrument 
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GRAPHIC- UND TABLE VIEWS 

User configurable windows with graphs and tables. 

SERIAL NUMBER, VOLTAGE OF THE BATTERY, INTERNAL CLOCK  

Display of the data of the connected instrument: serial number, voltage of the battery and internal clock. 
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The Menus 

FILE MENU 

The File Menu contains all the input/output functions.  

 

 

 

New 

Creates a new database file for data and parameters.  

 

If the new database already exists, the existing database is deleted after confirming the following message: 
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The new and empty database is displayed. 

 

New data can be entered in the database by importing or by starting a measurement. 

Open 

Opens an existing database. If there are already data in the database, the “Summary View” window appears. 
The type and serial number of the instrument can be chosen as well as the time range. The following example 
shows a database containing data from different FluoroProbes. 

 

Close 

Closes the active database. 

Import (FluoroProbe / AlgaeTorch / BenthoTorch)  

This function is used to import *.FLP files into the database. These files can be results transferred from the 
FluoroProbe to a USB stick or files generated by the first version of the FluoroProbe software. 
To import, please choose the file from the file system: 
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It is possible to select more than one file by pressing the shift key while selecting the file. 
FluoroProbe only: Afterwards choose how to apply the air pressure and hence the calculation of depth. 

 

AIR PRESSURE AS GIVEN IN FILE (FLUOROPROBE AND ALGAETORCH 100 ONLY) 

Air pressure was measured at the beginning of the measurement. This value is used. 

AIR PRESSURE FROM FIRST DATA SET (FLUOROPROBE AND ALGAETORCH 100 ONLY) 

The first measurement of air pressure took place in air. This is the appropriate selection if an autostart-plug 
without a PC was used (for further information see the FluoroProbe-manual). 

AIR PRESSURE (FLUOROPROBE AND ALGAETORCH 100 ONLY) 

Allows the entry of a constant value. To be used if the FluoroProbe was submerged for a longer time and unable 
to measure the air pressure by itself. 
In case of FluoroProbe data, the results are recalculated from the raw data after importing. 

 

The calculation procedure takes place in subsequent steps. After importing all data, a success message is 
shown. 
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Export (ASCII) 

This item exports the data as an ASCII file to load them into other programs. To select columns to be exported 
and the separator that is used, please see the description of the View Editor. The view editor allows the user to 
define different export formats for each instrument. All export formats of the current instrument are shown in the 
menu: 

 

The default export view is “Export all”. 
After clicking on “Export all”, the name and folder of the exported file can be selected. 
Hint: To transfer data to Excel, use the copy and paste feature in the “Edit” menu. 

Export (Database) 

This item is used to export parts of a database to a new (and smaller) one. The exported database can be read 
with bbe++ again. This might be useful when parts of the database are transferred via email. 
The currently selected data (“WINDOW → SELECT DATA”) are exported. 

Export (KMZ) – AlgaeTorch / BenthoTorch / FluoroProbe 

This item is used to export geo data from instruments with GPS receiver to be displayed in Google Earth. 

Export (ToxTest protocol) – AlgaeLabAnalyser only 

This item is used to export the results of toxicity tests conducted with the AlgaeLabAnalyser to Excel. 

Summary View 

Opens a new window that gives an overview of all the data and instruments in the current database: 

 

The database bbe++.bdb above contains data of two types of instruments: AlgaeTorch and FluoroProbe. 
The serial numbers and the point in time of the first measurement and the last measurement stored in the 
database are shown below the heading with the name of the instrument. 
The header of the window (bbe++.bdb [FP-18-03] :3 has the following meaning: 

• the name of the database      bbe++.bdb 
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• the serial number of the instrument 

for which the data in the data windows are currently shown  [FP-18-03] 

• the number of the window if there is more than one open window :3 

The summary view can be used to directly access the data or parameters of one of the listed instruments. To do 
so, use the right mouse click on the serial number: 

 

A selection of different periods and parameters are shown. After selecting one of the given periods, it is shown 
using the default view.  

 

For further information about the parameters window, please see the chapter Parameters. 

1. ... 2. ... 3. ... 

Names of the last database files opened for quick reload. 

Data Directory 

Opens the explorer with the current data directory to copy or rename the data base. This is the same function as 
in the start menu up to Windows 7. 

Exit 

Terminates the program. 
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EDIT MENU 

This menu contains commands to copy data/graphics from bbe++ and add them to the clipboard. 

 

Copy 

The content of the active window will be copied to the clipboard. Depending on the type of the active window, 
this is either a graph or a table. 
Tables can be pasted to EXCEL directly. 

HOW TO COPY DATA TO EXCEL: 

Use “WINDOW → SELECT DATA” to select the data you want to copy to EXCEL. Use the list window type that 
contains all the columns to be exported. Please note: only the columns from the active view are exported. 

 

• click on “EDIT → COPY”  

• open Excel with an empty datasheet 

• click on “EDIT → PASTE” in Excel 
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Now the data can be used for all kinds off calculations within Excel. 

Edit Comment – advanced functionality only 

To edit the comment of one or more datasets mark the datasets in the table view. A dataset can be marked with 
a mouse click. Multiple datasets can be marked be pressing Ctrl key while clicking on the dataset required. 
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Go to Edit → Edit comments or use right click on the marked datasets: 

 

Enter the new comment for the selected data: 

 

Click OK: 

 

Delete Data – advanced functionality only 

To delete data, mark the datasets as described above. 
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Go to “EDIT → DELETE DATA” or use right click on the marked datasets: 

 

Click OK to delete the data. 

 

 

PARAMETERS MENU 

 

 

Item Function Available for 

History 
Display parameters of datasets stored in the 

database 
All instruments 

Template 
Apply a user-defined selection of parameters 

to an instrument 
All but AlgaeTorch and BenthoTorch 

Online 
Display and change parameters in the 

instruments 
All but AlgaeTorch and BenthoTorch 

Recalc 
Recalculate the datasets in the database with 

another set of calibration parameters 
All but AlgaeTorch and BenthoTorch 

Parameterset 
Select a parameter set from the ones stored in 

the instrument – see description below.  
FluoroProbe with parameter sets 

 

 

The first 4 selections in the menu lead to one tab of the Parameters window. 

Please note: 
Only parameters of the current type of instrument are shown. 
It depends on the user level, whether a parameter is shown or not. The higher the user level, the 
more parameters are shown. 

For example of parameter listings for user levels, please see the examples below. 
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Access level “advanced functionality”: 

 

Access level “User”: 

 

Depending on the parameters and on the access level, the parameters are read only  or read and write . 
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Overview 

 

TYPE OF OPERATION 

The selection of the type of operation corresponds to the commands in the menu. Depending on the selection, 

different types of operations can be done. 

EXPLANATIONS 

Gives a short introduction to what can be done. 

BUTTONS 

Export: exports the current parameter set to another database for recalculation 

Clipboard: copies the current parameter set to the clipboard to paste it into another application such as Office 

Word or Excel etc. 

Upload: sends the parameters to the connected instrument 

Matrix: shows all the calibration parameters of the connected instrument in one window. 

NAME OF PARAMETER SET 

Each set of parameters can be identified by its time and date. Edited parameter sets or templates have an 

additional name given by the user. 

TYPE OF PARAMETER 

Each tab shows the parameters of a specific topic. 

Command buttons 

Type of operation 

Explanations 

Type of Parameter 

Name / Date of the parameter set 

Values 

Type of parameter set 
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VALUES 

Shows the current values of the parameters. Depending on the type of operation the value can be edited. 

TYPE OF PARAMETER SET 

Indicates the type of parameter set: 

Original: this parameter set has been used originally for a measurement, it cannot be deleted. 

Adapted: this is a parameter set has been adapted by the user, it can be used to recalculate the datasets. 

 

Shows the current values of the parameters. Depending on the type of operation the value can be edited. 

History – advanced functionality only 

Displays the parameters of the active dataset. 
The history is also available on the Context Menu in table view: 
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All parameter sets in the database can be displayed. To choose one parameter set, select the date from the 
drop-down box: 

 

 

 

VIEW MENU 

 

Toolbar 

Displays or hides the toolbar. 
The toolbar allows quick access to some important instructions: 
 

 
 
 
 

New database 

Open database 

Copy graphic or table to clipboard 
 

Open the Settings dialog 
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Status Bar 

Displays or hides the status bar. 

 

 

Measurement 

Displays / hides the measurement toolbar.  
The toolbar “Measurement” is different for each type of instrument. It allows quick access to functions such as 
starting and stopping the measurement or retrieving the parameters.  
The measurement toolbar of the FluoroProbe is given here as an example: 

 

 
In case of the AlgaeOnlineAnalyser or AlgaeLabAnalyser a progress bar is integrated 
 

 
 

Batch (AOA only) 

 

 
 
In case of activating the batch mode, pumping and cleaning can be controlled by the user. The measurement is 
started with the start button in the measurement toolbar – but the selected sample has to be pumped in by 
clicking the pump button.  
The checkboxes Transmission and Cleaning activate or deactivate the Transmission measurement and the 
cleaning during the measurement process.  

Measurement mode (AOA and ALA only) 

 
The checkboxes Comment and Activity do have the same functions as described in the chapter “tools -> 
submenu. 

Macro 

The toolbar “Macro” contains buttons to access to the user-defined view macros. For details, please see the 
chapter “TOOLS” → “SETTINGS” → “MACRO MANAGER”. 

 

For the grey buttons, no macro has been defined. 

Data Navigation 

The toolbar “Data navigation” contains buttons to navigate within the data. “One page” corresponds to the time 
scale of the Concentration vs. Time graphs. 
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⧫ go to the first dataset 

⧫ one page backwards 

⧫ one page forwards 

⧫ go to the last dataset 

 

Period 

The toolbar “Period” contains buttons to scale the time axes to a given value: 

 

⧫ 1 hour 

⧫ 6 hours 

⧫ 1 day 

⧫ 7 days 

Session 

The toolbar “Session” contains buttons to navigate from one measurement to another. One measurement is 
defined as a number of consecutive data sets that do not differ in the point of measurement by more than a 
given value. This value can be set in “TOOLS” → “SETTINGS” → “DISPLAY”. 

 

Connection State 

The toolbar “Connection state” shows the status of the connection to the connected instrument: 

 

The colour indicates the status: 
Black:    Not connected, the PC has not tried to establish a connection 
Yellow, blinking: Not connected, the PC is trying to establish a connection 
Green:   Connected 
 
To open the COM port setting click the coneection state button 

Auto-Update 

If auto-update is activated and a new data-set is generated during the measurement, this data-set is shown in 
the graphic or list window. If the displayed period does not contain this current point in time, the displayed period 
is changed automatically, so that the latest data-set is shown. 
If auto-update is deactivated, the displayed period does not change. This is useful when doing data analysis 
during the measurement. 

Application look 

Changes the style of the application 
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Window – Advanced functionality only 

This menu contains commands to show, arrange and edit different views to display the data. 

 

New Table Window 

Opens a new window and displays the data according to the selected window type. 

 

(See below) 
Please see the list window “Concentration” of an AlgaeTorch as an example. 

 

New XYGraph Window 

Opens a new window and displays the data according to the selected window type. 

 

There are some view types pre-defined for each instrument. It is also possible to add new window types by 
using the view editor. 
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The following diagram shows the development of different algae classes measured with the bbe FluoroProbe.  

 

New Single Value View 

Opens a new window and displays the data of one data-set according to the selected window type. 

 

The data-set is shown in larger digits to help the user read the display even in bright sunlight. The latest data-
set is shown. 
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The “Single Value View” can be adapted to the screen by changing size and/or proportion of the window: 

    

 

Cascade 

Arranges the windows one behind the other. 

Tile Horizontally/Vertically 

Initiates the organization of the screen into mutually non-overlapping frames. 

Select Data 

The “Select Data” window can be used to select data of a specific instrument and a specific time range from the 
current database. 
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Type: shows the types of instruments available in this database. 
Unit: shows the serial numbers of the type of instruments chosen above available in this 

database. 

TIME RANGE 

Selects the time range of data to be selected. It is possible to select a fixed time range such as “last month” or 
to do a manual selection by entering a range FROM “date” TO “date”. 

Hint: Further selections can also easily be made in a graphic window. 

 

After selecting the time range, the data is shown in the default view. 

 

View Editor 

The View Editor is used to generate your own table or graphic window type as well as a template for the export 
to text files. The View Editor is an assistant that leads through the whole process. 
When starting the View Editor, the current view is selected automatically to be edited or used as a template for a 
new view. Other views may be selected. 
For each instrument there are pre-defined views. These views can be edited but not deleted. Changes in pre-
defined views can be reset to their original status. User-defined views can be edited and deleted. 

GENERATING AND EDITING A TABLE VIEW WINDOW 

To explain the function of the View Editor, in the following steps a table view showing date/time, total chlorophyll 
concentration, Bluegreen concentration and depth is generated as an example.  

View Selection 
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1. Open the view editor: 

        

2. Choose the type of instrument the view is to be used for (in the example “FluoroProbe”). 

3. Choose the type of view that is to be generated or edited (in the example “Table view / single value 
view”). 

4. Choose one existing view to edit or as a template for a new one. 

In case of a pre-defined view, the view can be reset to the original status (“RESET”). 
In case of a user-defined view, the view can be deleted (choose a custom view and click “DELETE”). 

5. Click “NEXT”. 

Field Configuration 

This window shows all available data of the selected instrument. The left column shows the data that is currently 
not used in the chosen view. In the right column are data that will be displayed in the resulting view. The order in 
the right column corresponds to the order in the table. 

 

6. Click on “Green Algae [µg/l]” and “ REMOVE” to remove the concentration of green algae from the 
view. 

7. Repeat with all entries but “Date/Time (date)”; “Bluegreen [µg/l]”, “Total conc. [µg/l]” and “Depth [m]”. 
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8. Click on “Total conc. [µg/l]” and ”UP” to change the order. 

 

9. Click “Next”. 

 

General Properties 

The General Properties page allows the user to change the background color of a “Single value” view. 

 

10. Click on the color picker box behind „Background color“ and choose a new color. 
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The chosen color is now shown in the color picker box 

 

Example of a change in background color: 

   

Save View 
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11. Enter a name for the view. 

 

12. Click “OK” to confirm. The current data is then shown with the new view. 

 

13. The new view is now available in the Window menu. 
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GENERATING AND EDITING A GRAPHIC VIEW WINDOW 

To explain this function, in the following steps a graphic view showing date/time and total chlorophyll 
concentration is generated as an example. 

View Selection 

1. Open the view editor: 

 

    

2. Choose the type of instrument the view is to be used for (in the example “FluoroProbe”). 

3. Choose the type of view that is to be generated or edited (in the example “Graphics view”). 

4. Choose one existing view to edit or as a template for a new one (in the example “Conc. / depth”). 

In case of a pre-defined view, the view can be reset to the original status (“RESET”). 
In case of a user-defined view, the custom view can be deleted (“DELETE”). 

5. Click “NEXT”. 

Independent Axis 
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6. Choose the design according to the given examples (in the example Y-Axis) 

 

Field Configuration 

7. Select the data for the axis chosen and click on “ADD→”. Only one of the available entries is possible (in 
the example “Depth”) 
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8. After choosing one entry all other entries vanish. Removing the entry by clicking “REMOVE” brings 
back all available entries. 

 

9. Click on „PROPERTIES“ 

Axis Properties - first axis 

Some properties can be set for each axis. For the first axis, this is the position and the direction. 

 

Normally the first axis is on the lower or left side of the graph. The direction is normally defined as: 
X-Axis: left side → low values right side → high values 
Y-Axis: bottom → low values top → high values 
To display e.g. chlorophyll concentration versus depth, it is easier to use the top position of the X-axis and to 
invert the direction of the Y-axis for the depth. Please see the following example: the first picture shows the 
standard settings, the second one with a direction-inverted Y-axis and inverted position of the X-axis. 
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10. Click “OK” to confirm the settings. 

11. Click “NEXT”. 

12. Now the data and settings for the other axis can be selected. 

Field Configuration - second axis 
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13. After selecting one type of data, only those types which have the same unit(s) remain in the right 
column. 

 

14. For example, “Total chlorophyll concentration” and “Bluegreen” have to be selected here. 
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Axis Properties - second axis 

For the second axis, the properties can be set as shown above. Additionally available scaling options are: 

 

Manual scaling: enter fixed values for the minimum and the maximum of this axis - enter 0 for both to 
disable this feature. 

Auto-scale on: enables the auto-scaling feature - the axis will be scaled so that all selected data are 
visible. 

Auto-scale limits: these settings are used to obtain a nice looking graph in two special situations:  
➢ datasets with very low noise: 

In the auto-scaling mode, the graph looks as if there are extreme variations, but the 
range is very small due to the auto-scaling. In this case, it is better to use the option: 
lower limit: lower than and 
upper limit: higher than  
This leads to a minimum span in the graph. 

➢ datasets with outliners: 

In this case, it is difficult to analyze the data because the auto-scaling generates a 
high span value. To prevent this, please use: 
lower limit: higher than for outliners with low values  and 
upper limit: lower than for outliners with high values 
This leads to an optimized span in the graph. 
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15. Click “Next” 

Attributes 

This sets the color and size of the dots and lines as well as the color of the background. 
16. Set the value in the attributes window according to your needs. 

 

Pixel number: enter the dot size of the value points.  
Background color: click on the colored button to change the background color of the graph. 
For illustration, please see the examples with connected and unconnected dots, different sizes and background 
colors. 
Different dot sizes: 

    

Different background colors: 

    

Column Attributes 
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Select a dataset. 
Color: select a dataset and click on the colored button to change the color of the dots. 
Connected: check the box to connect the dots in the graph. 

 

Hint: The data points are not connected if the time of measurement differs more than the given 
value in “TOOLS → SETTINGS → DISPLAY”. 

 
Different dot colors: 

    

Unconnected dots / connected dots: 

    

17. Click “Next” 

Save view 
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18. Enter a new name for the view. It is not possible to edit pre-defined views. Please store a view based on 
a pre-defined view with a new name. 

 

19. The current data is shown using the new view after clicking “OK”. 

 

GENERATING AND EDITING AN ASCII EXPORT 

View Selection 
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1. Open the view editor: 

 

2. Choose the type of instrument the export is to be used for (in the example “AlgaeTorch”) 

3. Choose the type of export that is to be generated or edited (in the example “ASCII export”) 

4. Choose one existing view to edit or as a template for a new view. The delete button is used to delete a 
view. It is not possible to delete pre-defined views. 

5. Click “NEXT” 

Field Configuration 

This window shows all available data of the selected instrument. The left column shows data which are not 
currently used in the chosen view. In the right column are data that are to be displayed in the view. The order in 
the right column corresponds to the order in the table. 

 

6. Select the required datasets from the right column. Use the up and down buttons to determine the order 
of the data in the export table. 

7. Click “Next”. 
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8. Define separator and end of line characters according to the needs of the importing software. 

9. Click “Next”. 

Save View 

10. Enter a new name for the view. It is not possible to edit pre-defined views. Please store a view based on 
a pre-defined view with a new name. 

 

11. The new view is now available in the “File” menu. 

 

Comment Fields 

For each type of instrument, special comments can be defined. These comment fields can be used at the 
beginning of the measurement. The comments names and types can be defined within this dialog. 
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Type of instrument: the type of instrument is defined in the settings “TOOLS → SETTINGS → ACCESS“. 
Used: if tagged, the comment can be used at the start of the measurement, otherwise the 

comment is hidden. 
Description: name of the comment 
Type: “Text” allows entry of text, “Number” allows digits only; this is relevant for the way the 

comments are sorted in a list view.  
Template: stores the comment definition to transfer it to a new database; the transfer is done 

when opening a new database. 

1. ... 2. ... 3. ... 

Shows all the currently opened windows. 
 
 

TOOLS 

Menu (advanced functionality) 

 
 
Menu (basic functionality) 

 

Settings 

Here, all the preferences for the general functionality of bbe++ can be set. 

DATABASE 

The ‘Database’ tab shows the currently used database. The checkbox can be used to open this database after 
starting bbe++. We recommend you to store all the data in the same database. 
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Automatic start of measurement 

For continuously working instruments (AOA or FluoroProbe / AlgaeTorch) the software can be configurated to 
start the measurement directly after starting the software. The feature can be used to ensure, that the 
measurement starts again after a power fail. 

Auto Archive 

If there are many datasets in the database, navigation in the database becomes slow. The “Auto Archive” 
function automatically archives older data in the database. If there are data older than – in the example – 60 
days, the auto-archive function is started. Only datasets that are a maximum of 30 days old remain in the 
database.  
The archived data is written in a database similar to an exported database. The name corresponds to the date 
of the first dataset in this database. 

DISPLAY 

Enter the time period which defines the maximum interval between two measurements of the same series. The 
setting is used for the “Next measurement” button in the toolbar. 

 

Next and previous measurement buttons in the toolbar.  

 



The Menus 

bbe AlgaeTorch Manual   Page 83 

Furthermore, this setting is used to control the drawing of lines between two dots. If the interval between two 
measurements is shorter than the given interval, a line is drawn – otherwise not: 

 

 

ACCESS 

Depending on the access level selected, the software shows more or fewer options. The main difference is the 
number of items shown in the menus and the number of parameters shown. 

Minimal interval set to 10 minutes 

Minimal interval set to 1 minute 
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If an instrument with editable parameters is connected, the same setting is maintained for editing. 

 

User-levels: 
Level     Access 

Basic functionality • Just basic operation of the instrument 

• Measurements with pre-defined parameters only 

Advanced 
functionality 

• All menus accessible / all parameters customizable 

 
The “Advanced functionality” level can be password-protected. As soon as the checkbox is ticked, a password 
can be entered. Afterwards the password is required to enter the Advanced functionality level. 

Please note: 
The “Advanced functionality” level remains until “Basic functionality” level is chosen again. 
Even when restarting the software, the “Advanced functionality” level and a given password 
will still be valid. 

 

Default Device 

The bbe++ software is able to control different types bbe instruments, but only one type at one time. The type of 
instrument is entered here. Various settings within the bbe++ software can only be made for the default type 
instrument. To make entries for an other type of instrument, the default type has to be changed before. 

Offline Mode: 

Choose the offline mode to display data of different type of instruments. If the offline mode is active, no 
measurement is possible. 
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MACRO MANAGER 

The bbe++ software provides the option to store the arrangement of the view windows. One of the stored views 
can be used as the default view automatically displayed after starting bbe++. 

  

 
To generate a new view macro: 

1. Arrange the windows. 

2. Enter the name of the new view. 

3. Check the “Use at program start” box as required. 

4. Confirm. 
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LOGGER SETTINGS 

The logger settings are used in case of problems with the bbe++ software. Please ask the bbe service for 
advice. 
Depending on the checked options more or less information is stored in the file “error.log” in the program folder 
of bbe++ software. 

 

SHORTCUTS 

With the F8 key, one single view can be retrieved. Please enter the single view macro to be used for this. 
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F8 shows the selected macro 

LANGUAGE 

This tab shows a list of the available languages of the bbe++ software. To change the language, choose the 
language you wish and click “OK”. The bbe++ software must be restarted for the changes to take effect. 
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IO MODULS 

This item is used to connect an IO module (for example 4-20mA or relay outputs) to the PC.  

 
• the COM port can either be chosen from the drop down box or the software can search all COM ports 

for the selected instrument. 

• once an instrument has been found the COM port is stored for the next use. 

• To configurate the devices goto Tools -> device -> … . This item is not available for all instruments. 

 
With “search MCU” a multi channel unit for the AlgaeOnlineAnalyser can be conncted. 
 

TEXT RESULTS 

This item is used to do the configuration of writing text files and sending data via RS232. 
  

 
 

FILE OUTPUT 

If the file output is configured daily text files are written by bbe++. The files are stored in the path given in “file 
path”.  
The name is the serial number of the instrument date: 
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The format of the output is defined by a “view” of the type “ASCII export”. For details please see the chapter 
“view editor”. In the view editor the data columns and the format can be defined. 
Files older than given in the “max. age of files” are deleted automatically. If this is set to “0” no files will be 
deleted. 

Enable advanced/basic functionality 

Change between advanced and basic functionality. See also Tools -> Settings -> Access. 

Connect COM port 

 

This item is used to connect an instrument to the PC. 

Please note: 

• bbe++ is looking for an instrument of the selected type only (Tools → Settings → Access). 

• the COM port can either be chosen from the drop down box or the software can search all COM ports 
for the selected instrument. 

• once an instrument has been found the COM port is stored for the next use. 

Device 

The “Device” submenu varies depending on the selected type of instrument. Each type has its own submenu. 

DEMOMODE 

To switch the bbe++ software to the demo mode select FluoroProbe (Tools -> Settings -> Access) and 
disconnect all instruments. Click on “DEMO mode” in the device submenu. Now, the software can be operated 
as if a FluoroProbe were connected. Some procedures such as calibrations are limited in function. 
To reset the demo mode, please restart bbe++. 

 

Once the DEMO mode is selected, the submenu changes to the FluoroProbe entries: 
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ALGAETORCH / BENTHOTORCH SUBMENU 

 

 
 

Enter comment at start of measurement: 

Check to enter one or more comments when starting the measurement procedure. 

Force import of all data 

The import starts with the latest data. If there are data already in the database, the import stops. The software 
does not look for older, not-imported data to reduce the importing time. 
 
If older data are to be imported, this flag has to be activated. If activated, all data from the FluoroProbe are 
imported. Datasets already in the database are skipped. 

Synchronize device with PC time 

To set the clock of the FluoroProbe, synchronise it with the clock of the PC by activating “Synchronize with PC”. 

Get data from device 

Imports parameters and the latest data that have not been imported yet. The import starts with the latest data. If 
there are data already in the database, the import stops. The software does not look for older, not-imported data 
to reduce the importing time. 

Parameters utility 

Receiving the complete parameters set from the AlgaeTorch / BenthoTorch and sending a Parameters file to the 
instrument. This is supplied by the bbe service in most of the cases. 
 

 
 

 

SQL Script 

This function can be used to run an SQL script on the database to reorganise it or to do some special 
calculations. The SQL script is provided by bbe Moldaenke as the case arises. 

 

Calibration 

 

 
 
To calibrate the Torches please use the calibration menu of the internal software.  
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The Views 

TABLE VIEWS 

A table view is opened by “WINDOW → NEW TABLE VIEW → TABLE VIEW NAME“.  

 

Within the list view, the right mouse button offers detailed information about the selected data set. 
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History of Parameters 

HISTORY OF PARAMETERS shows the corresponding parameters for the given instrument and time. For details, 
see the description of the data menu. 

 

Edit comment 

EDIT COMMENTS allows the user to change the comments of a specific data set retrospectively. 

 

The dropdown list contains previously entered comments (if applicable). 
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Delete data 

To delete data rows from the data base, mark one or more row by clicking on the row.  
Hold the Ctrl. key while clicking to add more rows to the selection. 
 

 
 
Hold the Shift. key while clicking to expand the. 
 

 
 
Select “Delete Data” 

 
 
All data or the selected only can be deleted. Click OK to delete. 
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Data Fields Selection 

To add or remove columns from the list view use “Data fields selection”. The dialog is similar to the dialog of the 
View Editor. 

 

Please select or deselect the columns. The list view is updated immediately. 

Sorting of the list view 

The list view is sorted by date/time. It can be sorted by any other column by clicking on the header of the 
column. Clicking twice leads to the reversed order. 
 
Sorted by time/date ascending: 
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Sorted by time/date descending: 

 

 
Sorted by green algae descending: 

 

XY GRAPH VIEWS 

Features of the XY graph view: 

4. Select data of interest 

5. Scaling of the axes (right click) 

6. Display of the corresponding parameters (right click) 

7. Editing a XY view, to change colours the type of graph. 

8. Navigation within the data 
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Select data of interest 

Please click and draw the mouse to select the required data. 

 

A pop-up window is shown to choose the axis to which the selection is to be applied. 

 

 

X only only the selection on the horizontal axis is applied. 
Y only only the selection on the vertical axis is applied. 
X and Y the selection on the horizontal and the vertical axis is applied. 
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X only applied 

Y only applied 
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Right-click menu 

 

Features: 

➢ adjust the scaling . 

➢ activate and deactivate of the autoscaling feature. 

➢ show the parameters of a single data-set. 

➢ return to the default scaling. 

Scaling of the axis 

By default, scaling is done automatically. This means, all datasets of the selected period are displayed. To have 
a closer look at the data, it is sometimes useful to change the scaling. In the right-click menu, there is a “Scale 
axis” option: 
In case of a time axis, the scaling tab of this axis is as follows: 

X and Y applied 
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The first and last point in time have to be entered. 

Hint: For more information on scaling an axis please see the "window" section in this manual. 

In case of a “non-time axis”, more possible adjustments are available: 

  
 
Manual scaling: enter fixed values for the minimum and the maximum of this axis - enter 0 for both to 

disable this feature. 
Auto scale limits these settings are used to obtain a nice looking graph in two special situations:  
 

• data sets with very low noise: 

In the auto-scaling mode, the graph looks as if there are extreme variations, but the range 
is very small due to the auto-scaling. In this case, it is better to use the options: 
lower limit: lower than and 
upper limit: higher than  
This leads to a minimum span in the graph. 
 

• data sets with outliners: 

In this case, it is difficult to analyse the data because the auto scaling generates a high 
span value. To prevent this, please use the 
lower limit: higher than for outliners with low values  and 
upper limit: lower than for outliners with high values 
This leads to an optimised span in the graph. 

Autoscaling  

Enables the auto-scaling feature. The axis will be scaled so that all selected data are visible. 
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Parameters 

Show the parameters of the data-set 

Default scaling 

Click here to undo all the changes in the scaling options. 
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Parameters 

 

Access 
Level 

Name Dimensio
n 

Meaning 

User Serial number  Serial number of the hardware 

User Software version (major)   

User Software version (minor)   

User LED warmup time s Time to warm up the LEDs before 
a measurement takes place 

User Measurement time s Duration of one measurement 

User Measurement interval s  

User Cellcountmode  Switches between “µg Chl A/l” 
and “cells/l” 

Service Wavelength LED0 nm For information only 

Service Wavelength LED1 nm For information only 

Service Wavelength LED2 nm For information only 

Service Wavelength LED3 nm For information only 

Service Measuring type  Switches between single, 
continuous and interval 
measurement  

Service Fingerprint LED 0 Cyanos digits/µg/l Result of the calibration of cyanos 

Service Fingerprint LED 1 Cyanos digits/µg/l Result of the calibration of cyanos 

Service Fingerprint LED 2 Cyanos digits/µg/l Result of the calibration of cyanos 

Service Fingerprint LED 3 Cyanos digits/µg/l Result of the calibration of cyanos 

Service Fingerprint LED 0 green 
algae 

digits/µg/l Result of the calibration of green 
algae 

Service Fingerprint LED 1 green 
algae 

digits/µg/l Result of the calibration of green 
algae 

Service Fingerprint LED 2 green 
algae 

digits/µg/l Result of the calibration of green 
algae 

Service Fingerprint LED 3green 
algae 

digits/µg/l Result of the calibration of green 
algae 

Service Offset LED 0  digits Signal of pure water 

Service Offset LED 1  digits Signal of pure water 

Service Offset LED 2  digits Signal of pure water 

Service Offset LED 3 digits Signal of pure water 

Service Cellcount factor Cyanos cells/µg/l Factor to convert µg/l in cells /l 

Service Cellcount factor green 
algae 

cells/µg/l Factor to convert µg/l in cells /l 

Service Global correction factor 1/100 Factor to adapt the results to a 
local reference method 

Service Gradient turbidity 1/10 
FTU/digit 

Result of turbidity calibration 

Service Offset pressure 1/100 digits Result of pressure calibration 

Service Gradient pressure 1/1000000 
mbar/digits 

Result of pressure calibration 

Expert req. val. LED 0 [nm] digits For brightness control 

Expert req. val. LED 1 [nm] digits For brightness control 

Expert req. val. LED 2 [nm] digits For brightness control 

Expert req. val. LED 3 [nm] digits For brightness control 

Expert Name algae class 0   

Expert Name algae class 1   
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The GPS module 

THE GPS MODULE OF THE BBE ALGAETORCH AND BBE BENTHOTORCH 

GENERAL REMARKS 

The bbe AlgaeTorch and bbe  BenthoTorch are equipped with a GPS module that allows the user to determine 
the position of each measurement. The position data are stored additionally with each dataset within the 
instrument. 
 
For data evaluation, the results can be read from the instruments display or transferred to the bbe++ PC 
software. bbe++ offers an export of the data to Google Earth to display the chlorophyll results on a map. 
 
The GPS module is made for outdoor operation. Within buildings, the satellite signals cannot be detected. For 
this case, the GPS module can be deactivated.  
 
Please note: 
After starting the Algae- or BenthoTorch especially after a longer time or after transporting the instrument, it 
takes some minutes to obtain the correct position. 

ACTVATING AND DEACTIVATING 

To deactivate the GPS module (it is activated by default), go to “Settings -> GPS -> GPS mode”, to deactivate 
the GPS. 

GPS is currently 
   on    

OK   on   off   ESC 
 
If the GPS is activated and the position has been found, this is indicated on the display: 
 

bbe AlgaeTorch  
01.06.2010   GPS 
12:00:00    menu 

 

POSITION (SETTINGS -> GPS -> POSITION) 

This screen is only available if the signal quality is sufficient.  
 

54°20.3644`N 
10°05.8699`E 

Sat: 5 Q: 92%  OK 
 
Sat: Shows the number of satellites from which the GPS module receives signals. 
Quality: Shows the quality and hence the precision of the position.  
 

REQUIRED QUALITY (SETTINGS -> GPS -> REQUIRED QUALITY) 

The quality of the GPS signal is so much the better the more satellites are available and the better the satellites 
are distributed. The quality is calculated. The required quality is the quality of the GPS signal that leads to an 
instant automatic start of the measurement. If the quality is insufficient, the GPS measurement can be skipped. 
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REQUIRED QUALITY 
   95%    

OK   +   -   ESC 
 
95% is the standard quality value. 

VERSION (SETTINGS -> GPS -> VERSION) 

  
 

AXN-1.30 0145 
Fasttrax IT500 
                  OK 

 

STARTING THE MEASUREMENT 

If the GPS module activated, the status of the GPS signal is shown after starting the measurement. If the given 
quality criteria are met, the measurement starts automatically, otherwise, the poor positioning information can 
be used (takepos) or the GPS information can be skipped. 

 

PosFix  Num   Quali 
YES        4        95% 
takepos.         skip 

 
In case there is no GPS signal e.g. within buildings, only “skip” is available. 

DATA EVALUATION WITHIN THE TORCH: 

To view the measured data go to “Data -> View”: 
The display shows the date and time of the latest result. Touch “more” as long as longitude / latitude can be 
read: 
 

54°20.3644`N 
10°05.8699`E 

more  <-  ->  ESC 
 

DATA EVALUATION WITHIN BBE++ 

After importing the data to bbe++ go to “Window -> New list window -> Default” to display results and position: 
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If the longitude / latitude columns are not available, use the right mouse button “-> Data selection” to add these 
columns. 
 

 

DATA EXPORT TO GOOGLE EARTH 

To display the data with Google Earth, execute the following steps: 
 

• Activate the GPS measurement within the Algae/BenthoTorch 

• Conduct the measurements 

• Transfer the data to bbe++ on your PC 

• Select the data you want to display  

• Go to File -> Export (KMZ) and create a KMZ file 

• Download and install Google Earth (http://www.google.de/intl/en/earth/index.html) 

• Go to File -> Open within Google Earth and open your *.KMZ to display it 
 
Example of data display using Google Earth: 
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Update of the firmware 

  
To update the internal software,the following steps are necessary: 

 
1. Get the Software “BBEFirmwareTool.exe” from bbe service 
2. Get the latest firmware version from bbe service 
3. Charge the AlgaeTorch resp. BenthoTorch 
4. Connect the AlgaeTorch/BenthoTorch to a PC  
5. Start BBEFirmwareTool.exe: 

 

 
 

6. Choose the COMport 
7. Select the firmware update file from your PC 
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8. Click OK. The software starts checking the device, its current software version and the status of the internal 
battery. If everything is fine, the firmware update starts. Afterwards the AlgaeTorch/BenthoTorch reboots. 

9. The version of the current firmware can be checked at the device display in the settings menu (Settings -> 
SW version). 
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How to access to an AlgaeTorch by ModBus 

 
To access the AlgaeTorch by ModBus, the serial protocol needs to be set accordingly (AlgaeTorch -> settings -
> serial protocol).  
 
Available values per Read Input Registers (Modbus function 0x04) 
 

Register 1..n Value  Comment  

1 Hi-Word constant 1234.56 BE constant float value: 1234.56 

2 Lo-Word       

3 Hi-Word Date BE float representing day 

4 Lo-Word Date  

5 Hi-Word Time BE float time   

6 Lo-Word Time  

7 Hi-Word Total [ug/l] BE float total chlorophyll 

8 Lo-Word Total [ug/l]  

9 Hi-Word Cyanobacteria [ug/l] BE float cyano 

10 Lo-Word Cyanobacteria [ug/l]  

11 Hi-Word Total [cells/l] BE float 

12 Lo-Word Total [cells/l]  

13 Hi-Word Cyanobacteria [cells/l] BE float 

14 Lo-Word Cyanobacteria [cells/l]  

15 Hi-Word FTU                      BE float 

16 Lo-Word FTU                           

17 Hi-Word Depth [m] BE float 

18 Lo-Word Depth [m]  

2342 Word Device address BE word (r/w) 

 
Please note:  
 

• Date and Time, added together, are representing Date and Time as an MS-Excel compatible value (e.g. 
days since 31.12.1899). 

• If device has no FTU option FTU will read -1.0. 

• If device has no pressure option Depth will read -1.0. 

• Use Write Single Register (Modbus function 0x06) to change value of register 2342. Acceptable values 
are from 1 to 247. Answer to write will contain old device address. Further communication must use new device 
address. Default address is 1. 
 
BE = Big endian 
 
There is PC software available to check the MODBUS functions. For example: 
 
http://www.modbustools.com/ 
http://www.chipkin.com/products/software/modbus-software/cas-modbus-scanner/ 
 
 
In case of questions contact bbe service. 
 

http://www.modbustools.com/
http://www.chipkin.com/products/software/modbus-software/cas-modbus-scanner/
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Use of the AOA protocol for the AlgaeTorch 

 
To access the AlgaeTorch by AOA protocol, the serial protocol needs to be set accordingly (AlgaeTorch -> 
settings -> serial protocol) in the AlgaeTorch. 
 
The PC or data logger needs to be set to  
 
Baudrate: 19200 
Parity:  N 
Databit: 8 
Stopbit  1 
 
The protocol is ASCII-based. The AlgaeTorch waits for a character and sends an answer as soon as a 
command has been recognized. The following commands are allowed:  

 

• “h” request for the header with the names of the single data. 

• “u” request for the units of the single data. 

• “d” request for the actual dataset. 

• “s” to start the measurement in the continuous mode or interval mode according to the settings of the 
AlgaeTorch. In this case there will be no answer string. 

• “p” to stop the measurement. In this case there will be no answer string. 
 
The answer is a string terminated with CR and LF. Each answer contains a fixed number of fields, separated by 
TAB. 
 
The “h” and “u” commands always return the same answers.  
 
The “d” command always returns the actual dataset. If there is no new dataset since the last request, the same 
dataset is delivered. 
 
The first field is the checksum of the whole string. The format of the checksum is a P (capital) and a two-digit 
hexadecimal number. The checksum is an XOR function of the following characters, excluding the TAB directly 
after the checksum and excluding the CR and LF. All the other TABs are included. The calculation of the 
checksum starts with 0. The 0 is linked by XOR to the ASCII number of the first character after the first TAB. 
The result is linked to the ASCII number of the second character, and so on. 
 
“C” example for the calculation of the checksum: 
 
char * response; /* response contains the complete response string */ 

int i = 4; /* Checksum and first TAB is not included */ 

unsigned char checksum = 0; /* First value is 0 */ 

 

while (response[i] && (response[i] != '\r') && (response[i] != '\n')) 

{ 

    checksum = checksum ^ response[i]; 

    i = i + 1; 

} 

 
The value in the checksum has to be the same as the two-digit number after the P. 
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The TAB-separated fields have the following meaning: 
 

 1 Checksum in the format "Pxx", where xx is a hexadecimal value in text representation for 
example  "P0F" - P: marker for checksum; 0F: hexadecimal representation of 15. This value 
depends on the string and is calculated as shown above. 

 2 Number of software version 

 3 Number of data fields "7" 

 4 Day, month, year in the format "DD.MM.YYYY" 

 5 Date and time in the format "hh:mm:ss" 

 6 Total Chlorophyll concentration in µg/l 

 7 Chlorophyll concentration of cyano bacteria in µg/l 

 8 Turbidity in FTU 

 9 Total Chlorophyll concentration in cells/l 

10 Chlorophyll concentration of cyano bacteria in cells/l 

 
 
Example for the communication (bold characters sent by the PC): 
 
h          

P61 01.00 7 date time total cyano turbidity total-cc cyano-cc 

u          

P5F 01.00 7   µg/l µg/l FTU cells/l cells/l 

d          

P3E 01.00 7 09.06.2016 06:50:10 138.5 138.5 0.0 138500000 138500000 
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Troubleshooting 

Please call us:  
Tel.: +49  431 380 40-40  
Fax.: +49  431 380 40-10 
e-mail.: service@bbe-moldaenke.de 
 
We will gladly help you. 

Instrument Does Not Start 

• rechargeable battery is empty 

• power supplier is not connected 

• timing problem when turning the AlgaeTorch. Try again a bit more slowly or quickly or use the magnetic 
switch. 

PC Does Not Recognise the AlgaeTorch  

• wrong COM port is being used 

• data cable or power supply is disconnected 

• the driver does not fit to the operating system. Please download the latest driver from 
www.bbe-moldaenke.de. 

• COM port is used by other software (mouse pad/IR interface), please refer the manual of the PC 

• a virus scanner is used that delays the data; deactivate the virus scanner and try again. 

Problems in Detecting Low Concentrations 

• avoid bright sunlight 

• recalibrate the offsets in ultra-filtrated sample water 

Problems with wrong readings 

• Please use the attachment for shallow water in case of low distances to the ground (> 25 cm) 

• use the black bbe calibration vessel in the lab 

• check, the front glass for air bubbles 

Problems in Detecting Algae Classes 

• recalibrate the offsets in ultra-filtrated sample water 

• you may have another type of cyanobacteria or green algae in the water. In this case, you have to calibrate a 
new algae class and use this one instead of the one calibrated by bbe. 
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Data and Tables 

Specifications 

Measurands Total chlorophyll [µg Chl-a/l], Concentration of cyanobacteria [µg Chl-a/l] 
Measuring range 0 - 500 µg Chl-a/l 
Resolution 0.1 µg Chl-a/l 
  
Weight 1.3 kg 

Size (H x ) 500 x 60mm 

  
Power supply 110/230 V - 50/60 Hz | 12V DC 
Power input 10 W 
  
Sample temperature 0 – 40 °C 
Temperature range (storage) 0 – 50 °C 
  
Protection class IP 68 
Depth range 10 m (AlgaeTorch 10), 100m (AlgaeTorch 100) 
  
Interface USB data port 
Accessories hard plastic carrying case, mains unit, manual, software, hand loop 
Options 10m rope, telescopic rod, nylon shoulder bag, SDI-12 with bbe converter 
  
Data capacity 2000 datasets (1000 datasets in Series 1 to 5) 
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Dimensions 
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